LABORATORY CHAPTER №11


MULTIMEDIA
Multimedia is the interaction of visual and audio information under the control of interactive software using modern technical and software tools, they combine text, sound, graphics, photos, videos in one digital representation.
Means of multimedia technology are divided into two classes. Based on the interaction and their application.
The first category (interaction) will correctly include the means of synchronous, asynchronous interaction, online mode. The second category (application) includes a variety of virtual objects, real video, audio, animation graphics, etc. To create and implement such technologies will require a PC, appropriate software, as well as means for constructing multimedia projectors for display on large screens. 
The purpose of multimedia technology may vary depending on the specific application. Typically, this is:
· popularization and entertainment;
· educational and scientific education;
· research, etc.
Considering in more detail each of them, it should be said that, for example, the popularizing goal is one of the main ones. Advertising activity actively uses multimedia in order to attract potential buyers and customers.

TOPIC 1. TYPES OF MULTIMEDIA. GRAPHIC
Bitmap graphics.
All images in PC are stored in digital form. The peculiarity of the bitmap image is that it, like a mosaic, consists of small cells - pixels. And the higher the resolution, the greater the number of pixels fit per unit area.
Example: resolution 600x800px. Literally this means the following: your picture contains 600 points vertically and 800 horizontally. If this image is not enlarged, viewed on the screen, then most likely the human eye will not notice the crista. If you start to enlarge or print on paper, for example A4 format, you will see a mosaic. The picture will be similar to the scheme for embroidering a cross.
[image: raster]
Bitmap images are used to transfer a smooth transition of colors, many shades. The most common application is photo processing, collage creation, etc. The most popular raster graphics editor is Photoshop. 
A Bitmap image takes up more disk space than the same, but is executed in a vector.
Bitmap images are used to transfer a smooth transition of colors, many shades. The most common application is photo processing, collage creation, etc. The most popular raster graphics editor is Photoshop. A raster image takes up more disk space than the same, but is executed in a vector.



Vector graphics.
Unlike a raster image, the vector image does not consist of individual pixels - pixels. The logic of the vector image is completely different. In vector graphics objects there are so-called reference points, between them - curves. The curvature of these curves is described by a mathematical formula. All this is done for you by the graphic editor. The designer arranges points and "pulls" the mouse with a curve that would achieve the desired shape.

[image: vector]
The most popular editors of vector graphics are CorelDraw and Adobe Illustrator. Vector graphics are often used in polygraphy: booklets, flyers, business cards, etc. products in which there is text, logo, ornaments-all that does not require the accurate transmission of all 18 shades of peach color, and can be described using curves. Often the vector images are called "in the curves".
The biggest plus of vector images is that even with a strong increase in the graphic object, the image quality does not change. The picture will be equally good if you print it out of a vector on a business card or print the same business card the size of a billboard.

Bitmap:
• Pros: very clearly and subtly conveys change-flow of colors, shades, shadows.
• Cons: loss of quality when zoomed in: the picture crumbles into colored squares - pixels; in high 
resolution takes up a lot of space.
• Scope: processing photos, creating layouts of sites, creating graphic objects with a large color gamut.
Vector Image:
• Pros: easy to scale - the image does not lose quality even at very high magnification.
• Cons: it is impossible to transfer smooth color transitions, as in a raster.
• Scope: printing, design of leaflets, booklets, promotional materials, business cards, logos, etc.
Experienced designers often combine the use of vector and raster graphics. But we must remember that a vector object can be converted into a bitmap easily, there are even online converters, but a raster object into a vector object is much more complicated. A qualitative automatic conversion from a bitmap to a vector is practically impossible.

TOPIC 2. TYPES OF MULTIMEDIA. VIDEO 

At its core, a video file is a set of static images that change each other with a certain frequency. Each static image is a separate video frame. This is true if we are talking about uncompressed video. However, no one keeps movies in this way. The fact is that uncompressed video takes up a lot of disk space. A PAL video (from analog camera) frame consists of 720 points horizontally and 576 vertically. That is, one frame consists of 414720 points. To store the color of each point in memory is allocated 24 bits (8 bits for each of the components of the RGB). Therefore, to store one frame, you need 9953280 bits (or about 1.2 MB). That is, a second uncompressed video in PAL format will take almost 30 MB. And one hour of this video - more than 100GB.
In general, video is stored in video files (containers) that use various information compression algorithms. Thanks to these technologies, a video file can be compressed tens or hundreds of times with almost no loss of picture and sound quality.
A container is a file that is used to store digitally converted analog information. A container is a file of a certain standard, which can simultaneously contain several different types of information.
The main types of media files:
· AVI (Audio Video Interleave) is a container format, which means that it can contain
audio / video compressed with various encoding combinations.
· MPEG (* .MPG, * .MPEG) - format for recording and playing video. It has its own 
compression algorithm. Currently actively used to record digital video.
· MKV - more advanced than the AVI standard - when playing large files there are no 
“lags” and“hangs up”, especially noticeable on not very fast computers. It can contain audio tracks in different languages, which AVI does not allow, it can also store information about chapters, videos, menus, etc. It may contain video data compressed with many codecs: MPRG, H264, AVC1, WMV, etc.
Windows Movie Maker software is a compact, easy-to-learn and yet powerful video editor that provides all the necessary tools for working with digital video. With this program, you can record a video from a digital camera to your computer's hard drive, cut out the desired pieces, edit, add still images, audio and video effects, transitions and titles.
Windows Movie Maker is included in the basic Windows package since version 2000 (the version of Windows Movie Maker Live is currently available), that is, unlike tools such as Adobe Premier and AfterEffects, Ulead MediaStudio and VideoStudio, as well as popular in the latter time Sony Media Software Vegas, it's free. Although WMM has a rather limited set of capabilities in comparison with the above programs, it is quite enough for entering the video stream into a personal computer and for composing a quality video.
























ADDITIONAL TASK FOR MASTERING SKILLS

ANIMATION OF IMAGE PARTS

1. Open Adobe Photoshop, Standard path: From: Program Files / Adobe / Adobe Photoshop / Photoshop.exe
2. Create a new document with dimensions, for example, 650x650 pixels, Background: white. File -> New. (Файл ->Создать).
3. Open chosen image (fold the Photoshop window halfway up the screen, drag and drop the file with your picture to the center of the Photoshop screen). Place it at the center of your document. The image should be smaller than the document itself (you can reduce and move the image by the corner point indicators.) After the size conversion is completed, press enter.
[image: ]














4. Set the Rulers as follows (divide into four equal parts). To make this tool active, click View> Rulers (Просмотр-Линейки)  or CTRL + R. To add guides, hold down the left mouse button on the ruler and drag down (for the horizontal guide) or to the right (for vertical).
[image: ]

5. Pick up the Rectangle marquee tool/ Прямоугольная область  (M) and create a selection around the top left of the picture.
5.1. Then click Layer> New> Layer via Copy / Слой - Новый - скопировать на новый слой (Ctrl + J) to copy the selection to a new layer.
5.2. Go back (select layer) to the main image and do the same with each part.
5.3. At the end, delete the layer with the picture.
6. Apply style to each Layer Layer> Layer Style> Blending Options:/ Слой - Стиль слоя - Параметры наложения.
[image: E:\PS\Анимация_files\animateh.jpg][image: E:\PS\Анимация_files\animateg.jpg]











6. Then press Ctrl + T or Edit> Free Transform (Редактирование - свободная трансформация) and apply this tool to each piece. Unfold them in some unique way.
[image: ]
7. Leave only one layer visible on the background (here it is layer 4)

[image: ]


8. Open the Animation palette: Window> Animation. An animation panel will appear in the bottom of the screen.
9. On the animation bar, click Create Frame Animation. The visible layer will immediately appear on the first frame:

[image: ]

10. Drag picture on visible layer to the upper right corner (using the Move tool /Перемещение (V)) so that only a small corner is visible.
11.  Click the Duplicates current frame button (Создать дубликат текущего кадра), which is in the Animation panel with frames (under frames).
12. Drag the picture in the working window again to the required place - in the center of the screen (on the second frame).
13. Select the two frames and click the Tween button. Set the following parameters:

[image: ]

14. Click OK. The frames will be reproduced. Click the Play button, and check the animation.
15. Next on the last frame, make another layer visible in the palette and repeat steps 10-14.
16. Repeat step 15 for each layer.
17. When you are ready, go to the menu File-> Save Optimized As ... (File - Save optimized as ...).
18. Select the necessary options for your gif file (size, color, etc.). Save the file in your working folder and check the result (Open your gif file in browesr).
19. Save your project File> Save As ... and save your project as a Photoshop file (* .psd)..

ANIMATION OF TEXT

1. Create a new document (Ctrl + N) with the size of 1000x1000pixels, 72 pixels /inch resolution, RGB color mode and transparent background.
2. Use the Ellipse Tool (U) to draw an ellipse (to switch different modes of single tool pres shift+hot key, in this case shift+u):
3. To draw a path, select Paths in the path settings:

[image: Движение текста по пути]
[image: ]

4. Press Ctrl + T and transform the ellipse, as shown below:

[image: ]

5. Press Enter to accept the transformation.
6. Select the Horizontal Type Tool (T) and click on the contour in a convenient place for you.
7. Type your text – short phrase (preferably to use font without anti-aliasing, to look at any background):
[image: ]
8. Switch to the Path Selection Tool/ Выделение контура (A). With its help we will move the text along the contour. With the mouse, drag the text to the inner side of the path (you can do not do this, proceed from your text length):
[image: ]

9. Apply to the text layer the Stroke effect (stroke):
[image: ]

10. Use the navigation bar to zoom in to the desired location (Window-> Navigator/ Окно-Навигатор).
11. Using the cursor, practice moving the text along the path. A cross and a circle on the contour are the boundaries of the text layer, you have to move both.
12. Duplicate the text layer (Ctrl + J) and shift the text along the path a bit. Focus on the bottom layer, which is visible:
[image: ]











13. Make bottom layer is invisible (press on eye button to the left of layer), and duplicate the upper one.
14. A new copy of the layer is slightly shifted, etc., until we reach the position on the contour of the first layer. Each shift will be displayed in a separate layer!
15. Select the Make Frames From Layers (Сделать кадры из слоев) from the Animation palette commands menu. Each layer produces a separate frame. The layer visibility properties will be set automatically.
[image: ]












16. Select all the frames in the Animation palette (click on the first frame and Shift + click on the last one) and set the delay to 0.1 sec:

[image: ]

17. Click on the Play button, and check the animation.
18. When you are ready, go to the menu File-> Save Optimized As ... (File - Save optimized as ...).
19. Select the necessary options for your gif file (size, color, etc.). Save the file in your working folder and check the result (Open your gif file in browesr).
20. Save your project File> Save As ... and save your project as a Photoshop file (* .psd)..


WINDOWS MOVIE MAKER

Creating a Project
1. Start Windows Movie Maker.
Launch Windows Movie Maker. The standard path is "C: \ Program Files \ Movie Maker \ moviemk.exe".
2. When you launch the program, a new project is automatically created. Choose the topic according to which you create the clip and save your project with the appropriate name. (File → Save Project).
Notice. The Windows Movie Maker project file has a .wlmp extension. This file does not contain fragments of video, graphics and music that you use, it contains only links to these files, so do not change or delete the imported files until the clip is complete, so as not to violate the referential integrity of the project.

Working with images

1. Import several images into your collection.
Click Add Videos and Photos («Добавить видео и фотографии»). Or left-click on the collection panel. (Note that as long as there is nothing in the collection, you can not import audio files).
2. Check your clip in the preview window.
[image: ]Once the files are added to the collection, the timeline and the menu bar "Edit" (Правка) are activated. To view the clip, press ►. To go to the next frame, press the ►▌ button.

3. Change the duration of the frames.
[image: ]Open the menu bar "Edit" (Правка). Select the desired frame and in the "Duration" (Длительность) window and specify the frame duration in seconds.fvs

Also, you can limit the time by moving the time slider to the required time and clicking "Set Endpoint" (Установить конечную точку). Thus, the frame will be cuted at this moment.
[image: ]

4. Set the required frame order.
To change the sequence of frames, select one or more of them in the collection and hold down the left mouse button and move them to a new position.
5. Add a visual effect to the frames
[image: ]Open the "Visual Effects" («Визуальные эффекты») menu bar and select one or more effects to apply to the selected frame. To delete an effect from a frame, select "Not selected" («Не выбрано») in the effect group. In the "Brightness" (Яркость) window you can control the brightness of the frame.

6. Add transition effects between frames.
Open the menu bar "Animation" (Анимация) and selectthe desired frame, give it an animation from the category "Transitions"(Переходы) . In the Duration window, specify the animation time in seconds.
[image: ]Additionally, you can select one of the zoom effects from the "Shift and Zoom" («Сдвиг и масштабирование») group.

7. Add text to the slide show
Open the menu bar "Home" (Главная) and select "Title" (Название). The panel "Tools for working with text" («Средства для работы с текстом») is displayed, in which you can add the name of the clip, adjust the size, type, duration of the text display and its duration, the color and background of the inscription and the boundaries of the text.
Select one of the effects for animating text from the Effects group.
[image: ]

To add text over the image, select the "Caption" (Заголовок) command. You can control the position of the text on the frame using the move indicator.
[image: ]

To add trailing inscriptions, select "Credits".
8. Save your slide show.
[image: ][image: ]To save, click "Save Movie" (Сохранить фильм) from the menu bar "Home" (Главная) or from the "File" (Файл) menu. Choose one of the options provided by the program. Or, specify your own settings - select "Create custom parameter" («Создать настраиваемый параметр).

Working with video clips

The operations of adding video to a collection, overlaying effects, animation of transitions between clips, and inscriptions are similar to operations when working with images.

1. Manage the duration of clips.
To edit the duration of clips, use the tools from the group "Edit" («Изменение») panel "Tools for working with video" (Средства по работе с видео) (the panel is displayed when there is a clip in the collection).
• Move the time slider in the preview window or on the scale of the collection and click "Set start point" (Установить начальную точку) at the point at which the video should start. (trimming frames at the beginning of the clip).
• Move the time slider in the preview window or on the scale of the collection and click "Set End Point" (Установить конечную точку) at the point where the clip should stop. (trimming frames at the end of the clip).
• Click "Trim tool" (Средство усечения) to set the exact cropping positions in seconds.
[image: ]To divide the video into different frames, move the time slider in the preview window or on the scale of the collection and click “Split”  (Разделить) at the point where you want to split the video.

2. Create a snapshot.
[image: ]To create a snapshot from the video, move the time slider in the preview window or on the collection scale to the chosen moment of clip frame and click Snapshot (Моментальный снимок) on the Home menu bar. Save the resulting file and it will be immediately added to the collection.

Working with audio files

1. To add music over the video clip and /or images, select "Add music" («Добавить музыку») in the menu bar "Home" (Главная). You can add music from the Internet and /or a local computer, and also record voice-over text from the microphone.
[image: ]
Imported music is displayed as a separate track under the frames.
[image: ]Music from the imported video file is displayed on top of the frame

2. To configure which of the audio tracks has priority and / or combine both tracks, open the Project («Проект») menu bar. And use the slider "Sound Mixer" (Звукового микшера) to set the priority for music clip (slider to the left) or added music (slider to the right). You can also use the command "Select Recorded voice / Video / Music" (Выделить закадровый текст/видео/музыку) to set the priority of the corresponding audio track.
[image: ]
3. To change the volume, as well as add the effects of rising and fading sound, set the required parameters in the "Sound"  (Звук) column of the "Music Tools" (Средства для работы с музыкой) menu bar (it becomes active when there is audio in the clip).
[image: ]

4. To change the duration, break the audio file into parts, set the beginning and end of the music you should use tools similar to video editing (splitting, setting the points of the start and end).
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